1С. Массивы

ДниНедели = Новый Массив();
ДниНедели.Добавить(“Понедельник”);
ДниНедели.Добавить(“Вторник”);
ДниНедели.Добавить(“Среда”);
ДниНедели.Добавить(“Четверг”);
ДниНедели.Добавить(“Пятница”);
ДниНедели.Добавить(“Суббота”);
ДниНедели.Добавить(“Воскресенье”);

БудниеДни = Новый Массив();

Для Каждого ТекущийЭлемент Из ДниНедели Цикл

Если ТекущийЭлемент = “Суббота” ИЛИ ТекущийЭлемент = “Воскресенье” Тогда
Продолжить;
Иначе
БудниеДни.Добавить(ТекущийЭлемент);
КонецЕсли;

КонецЦикла;

**********************************************************

СписокЛет = Новый Массив();
Для индекс = 2000 По 2020 Цикл
СписокЛет.Добавить(Индекс);
КонецЦикла;

ВисокосныеГоды = Новый Массив();
Для Каждого Год Из СписокЛет Цикл
Если Год % 4 = 0 Тогда
ВисокосныеГоды.Добавить(Год);
КонецЕсли
КонецЦикла;

*********************************************

Числа = Новый Массив();
Числа.Добавить(10);
Числа.Добавить(8);
Числа.Добавить(4);
Числа.Добавить(15);

ТекущийИндекс = Числа.ВГраница();
Пока ТекущийИндекс >=0 Цикл
Если Числа.Получить(ТекущийИндекс) < 10 Тогда
Числа.Удалить(ТекущийИндекс);
КонецЕсли;

ТекущийИндекс = ТекущийИндекс – 1;
КонецЦикла;