Метка: 1C

Выгрузка файла из 1с на веб сервер

Выгрузка файла из 1с на веб сервер, работает и на мобильной платформе У нас должен быть установленный веб сервер с PHP В каталог веб сервера передаётся файл send.txt. В параметре filename= задаётся имя файла и расширение файла, который выгрузится на веб сервер Код 1с [crayon-5dd1946b89201406380023/] В директории веб сервера должен лежать обработчик. В нашем случае это файл 2upload.php

Как вывести в 1с розница на дисплей покупателя 2 строки

Администрирование > Пользователи и права > Персональные настройки пользователей > Дополнительные права пользователей > снимаем галочку с “Автоматический расчет скидок при редактировании документа продажи“

1С. Массивы

ДниНедели = Новый Массив(); ДниНедели.Добавить(“Понедельник”); ДниНедели.Добавить(“Вторник”); ДниНедели.Добавить(“Среда”); ДниНедели.Добавить(“Четверг”); ДниНедели.Добавить(“Пятница”); ДниНедели.Добавить(“Суббота”); ДниНедели.Добавить(“Воскресенье”); БудниеДни = Новый Массив(); Для Каждого ТекущийЭлемент Из ДниНедели Цикл Если ТекущийЭлемент = “Суббота” ИЛИ ТекущийЭлемент = “Воскресенье” Тогда Продолжить; Иначе БудниеДни.Добавить(ТекущийЭлемент); КонецЕсли; КонецЦикла; ********************************************************** СписокЛет = Новый Массив(); Для индекс = 2000 По 2020 Цикл СписокЛет.Добавить(Индекс); КонецЦикла; ВисокосныеГоды = Новый Массив(); Для Каждого

Отключение пользователей 1С

8.1 Создаем ярлык. Назовем его: Отключение или Завершение. “C:\Program Files\1cv81\bin\1cv8.exe”  ENTERPRISE /F”ПутьКБазе” /N”Юзер” /P”ЕгоПароль” /WA- /AU- /DisableStartupMessages /C ЗавершитьРаботуПользователей При этом произойдет запуск программы под админскими правами пользователя , а на экране других выйдет сообщение, оповещающее об отключении. Сам пользователь отключится тоже через 60 сек. Ага, пользователи отключились, можно все что угодно делать с базой. А

В тонком клиенте 1с возникает такая ошибка “Обнаружено потенциально опасное значение Request.Path, полученное от клиента (:)”

В тонком клиенте 1с, запущенном под IIS, возникает такая ошибка “Обнаружено потенциально опасное значение Request.Path, полученное от клиента (:)” Мне помогла следующая настройка Пул приложений: Режим управляемого контейнера classic (предписывает выполнение ASP.NET в качестве расширений ISAPI)  

Как посмотреть список активных пользователей 1С на управляемых формах

В конфигураторе Список активных пользователей в конфигураторе можно получить через меню Администрирование ⇒ Активные пользователи. В окне отображается имя пользователя, режим запуска, время начала работы, имя компьютера и номер сеанса. Из этого окна можно открыть журнал регистрации действий интересующего пользователя. В режиме предприятия 1. Через меню «Все функции»: Функционал этого окна полностью повторяет рассмотренное окно в